Fantasy - Live beautifully, dream passionately, love completely

CentOS7 的FTP服务器配置

一、安装vsftpd及ftp命令
yum install vsftpd -y
yum install ftp -y
 
二、vsftpd服务器的配置文件
 
实现在开启防火墙和SELinux情况下,实现匿名用户的登录,可以上传下载,可以创建目录,创建权限掩码为022,可以删除文件,最大上传速度为100kbit/s。
 
vsftpd服务器的主要配置文件是/etc/vsftpd/vsftpd.conf。
1.服务器端设置
 
1.1修改配置文件开放匿名用户上传、下载及其他权限,
 
anonymous_enable=yes //允许匿名用户登录
 
anon_upload_enable=yes //允许匿名用户上传
 
write_enable=yes //赋予写权限
 
anon_mkdir_write_enable=yes //允许匿名用户新建文件夹
 
anon_other_write_enable=yes //匿名用户拥有除了上传和新建目录之外的其他权限
 
anon_amask=022 //匿名用户的权限掩码
 
anon_max_rate=102400 //最大上传速度100kbit/s
 
 
然后重启服务
 
systemctl restart vsftpd.service
 

阅读更多…

组播回忆小记

PIM有两个版本,一个spase mode 一个dense mode,主要的区别是在转发组播流量行为上,dense mode前提假设网络上(pim 区域)所有设备都是组播源的接收者,除非特别指明不接收。spase mode 前提假设你不想接收转发组播除非你特别告诉想接收组播流。

PIM dense mode是相当简单直接的转发方式,但是也相当浪费网络资源

PIM spase mode 主要核心概念是RP汇聚点,组播源就是树的根。但是如何让PIM区域里的路由器转发默认没有配置转发的组播流量,一个接收者可能说我想加入组播组239.1.1.1,但是如何让离接收者最近的路由器(也就是最后一跳路由器)知道往哪里发送 PIM JOIN msgs(就是告诉上游路由器它想开始接收这个组的组播流),再上一跳的路由器在把PIM Join msg发到哪。RP就是解决这个问题。所有的路由器表明它们想加入的特定组播组到RP,以及所有的流量源首先转发流量到RP,以至于让RP来转发后续的流量,这就是一个共享树

共享树(*,G)VS最短路径树(S,G)

2.SSM 指定源组播
使用IGMPv3    它的报文里指定了源ip
不建立(*,G) 表项,不需要RP
地址段 232.0.0.0/8作为SSM组播范围  

3.BIDir双向PIM
Bi-Dir 在从源端到RP之间路径上的路由器中,选择一个“指定转发器”(选择原则:到RP最优)

常用的100句英语口语

用餐常用英文

Hi, we need a table for two, please. 你好﹐我们有两位。

May we have a table by the window, please? 请给我们一个靠窗的桌子好吗﹖

We prefer to sit by the window, please. 我们想坐在靠窗的位子。

Can I take this seat? 我可以坐这个位子吗?

This table would be great. Thank you. 这个位子很好﹐谢谢。

May I have a menu,please? 请给我菜单。

Do you have a menu in chinese? 是否有中文菜单?

What’s your special today? 你们今天有什麽特餐﹖

What kind of dish is most popular here? 这裡最受欢迎的餐点是什麽呢﹖

I’d like to have some local food.我想尝试一下当地食物。

I cannot tolerate spicy food, could your chef make my dishes mild? 我受不了辣的菜﹐可以请厨师在我的餐点不加辣吗﹖

We need more time to decide what to order. 我们还需要一些时间来决定要点什麽。

Sorry, we still don’t have any idea of what to order, do you have any suggestions? 对不起﹐我们还是没有头绪﹐你有什麽建议吗﹖

I would like to have the same as the next table. 我想和隔壁桌一样的菜

OK, we’ll start with two glasses of iced tea, easy on ice, please. 请先给我们两杯冰茶,不要太多冰。

Excuse me, I’d like my coffee warmer. Could you please heat up my coffee little bit? Thank you!.请给我热一点的咖啡

Do you offer any set courses for party of two? 你们有没有提供2个人的套餐﹖

May I have another fork please? 请再给我一根叉子。

Could you give me a fork,please. 请你给我一根叉子。

Could you pass me the salt(pepper)? 请把盐(楜椒)传给我。

This is not what I ordered. 这不是我点的食物。

Is soda refillable? 汽水可续杯吗﹖

Some more water please. 请再帮我加些水。

May we have some more napkins? 可以再给我们一些纸巾吗﹖

We could like to order some desert now. 我们现在想点些甜点。

Excuse me, would you please show me where the restroom is? 麻烦告诉我厕所在哪裡。

We are ready for the bill now. 我们要买单。

Are we supposed to leave tips here? 我们需要付小费吗﹖

Is American Express(visa or master, travelers’ check…)

granted /accepted here? 你们收美国运通卡/visa/master/旅行支票吗﹖

What type of credit cards do you accept? 你们收那种信用卡呢﹖

Thank you for your service. We really enjoyed it. 谢谢你的服务﹐我们这餐吃得很好。

关注英语微信,每天学实用英语

\

换汇常用英文

Can you change this into Rupiah? 请将这些外币兑换成印尼盾?

I’d like some small change? 请将大钞换成零钱

交通常用英文

Is there an airport bus to the city? 这里有从机场去市中心的巴士吗 ?

Where is the bus stop (taxi stand)? 巴士车站在哪里 ?

How much does it cost to the city centre by taxi? 乘计程车到市中心需要多少钱

Keep the change, please 不用找钱了

Take me to this address, please 请拉我去这个地址

How long does it take to go to the city centre ? 到市中心需要多长时间?

Stop here, please 请停下来。

What time does it leave? 几点发车?

Where can I get a ticket? 在哪里卖票?

Could you tell me when we get there? 请问几点能够到达那里。

 

购物常用英文

Thank you but I’m just looking. 谢谢,可是我只是看看。

Let me look around a little more. 让我自己看看

Do you have this in another color? 这个有别的颜色吗?

May I try this on? 我可以试穿这个吗?

Is this tax free? 这免税吗?

Can I pay by credit card? 我可不可以用信用卡付帐?

Too expensive. How about a discount? 太贵了,打个折吧?

Still too expensive. Give me a better discount, and I’ll bring back my friends.
还是太贵了,再便宜一点吧,我会带朋友来。

Can you cut me a deal? 你可以算便宜一点吗?

Is this your final price? 不能再便宜了吗?

I want this, but in a large size. 我要大一点的

I would like to take this one. 我要买这个。

Please wrap this for me. 请帮我把这个包起来。

I’m looking for a gift for my friend. 我要买这个礼物送给我朋友。

What time do you open/close? 你们几点营业/打烊?

Where can I change money? 我要哪里换钱?

Where is the cash desk? 收银檯在那里?

饭店常用英文

I would like to have a morning Call at 8:00 in the morning.我要早上8:00设定电话叫醒。

I’d like to order room service, please.我要食物送到房间的服务。

I’d like a room of one.我要单人房。

I’d like a room for two with separate beds.我要两张床的房间。

I’d like as extra bed for room 702.我要在702房多加一张床。

When is check out time? 退房的适合时间?

I am interested in booking a room.我想订房。

Could I book a double room for 3 days from …(日期)..to(日期).
我要订一间双人房从….

How much is a double room for 1 night? 双人床一晚多少呢?

Your booking is confirmed.你的订房已经生效了。

Do you have a bus service from the airport? 有饭店的bus在机场接送吗?

Could you fax me a map of how to get to the hotel?
请你传真路线图给我,我想知道如何到你们饭店。

Could you show me my room? 你可以带我到我的房间吗?

Where is the emergency exit and staircase? 紧急出口和楼梯在那里?

Please send another blanket to my room.请再送一条毯子到我房间。

The sheets are dirty.床单很髒。

There’s no running hot water in my room.我房间没有热水。

I’ll arrive late, but please keep my reservation.我会晚一点到达,请保留所预订的房间。

I’d like a room with a nice view (a balcony).我想要一间视野好(有阳台)的房间。

What time does the dining room open? 餐厅几点开始营业?

What time can I have breakfast? 早餐几点开始供应?

Could you keep my valuables? 是否可代为保管贵重物品?

I’d like to check out. My bill, please.我要退房。请给我帐单。

Please bring me some ice cubes and water.请送给我一些冰块和水。

The air-conditioner (T.V. set、light) doesn’t work.冷气(电视、灯)无法开启。

CCIE-DC学习笔记4–OTV

交换机只有N7K支持 OTV ,路由器CSR也支持OTV

edge设备
每一个site最多2个edge设备

internal interfaces 内部接口 二层trunk

join interface 接入外网 IP 只有一个

overlay interface 逻辑接口 封装,解封装

原则与限制
1.OTV边界设备上 不能创建扩展VLAN的SVI
2.为一个overlayinterface只能指派一个join interface
3.同一个站点多个overlay interface可以共享一个site-vlan

OTV control Plane
邻居建立取决于广域网能力
1.支持组播 加入统一组播组
2.不支持组播 需要一个或者多个边界设备做比邻服务器

OTV二层故障域
1.站点间生成树隔离 BPDU不会通过overlay interface转发
不知道目的地的单播流量隔离
边界设备做ARP代理

AED 授权边界设备
在有2个OTV边界设备时,每个VLAN只由一个边界设备转发
基于HASH函数选择VLAN

OTV配置
feature otv
interface overlay0
descripticon West Site
otv join-interface E1/1
otv control-group 239.1.1.1
otv data-group 232.192.1.0/24 站点内组播流量
otv extend-vlan 100-150

otv site-vlan 99
otv site identifier 0x1 (OTV站点标示,同一站点内标示一致)

show otv vlan
show otv route

骨干网不支持组播情况下的OTV:
需要OTV adjacency 服务器

主用adjacency server 配置
interface overlay0
descripticon West Site
otv join-interface E1/1
otv extend-vlan 100-150
otv adjacency-server unicast only

备用adjacency server配置
interface overlay0
otv adjacency-server unicast only
otv use-adjacency-server x.x.x.x unicast only

使用备用adjacency server配置
interface overlay0
otv adjacency-server unicast only
otv use-adjacency-server x.x.x.x(主用) x.x.x.x(备用)unicast only

show otv adjacency

OTV新特性
一、环回口做join interface
join interface 只能用一个 ,出口有2个的时候,可以用环回口,防止单一接口DOWN

二、Authentication
1.数据层面认证(认证不通过,可以建邻居,发不了数据)
key chain OTVkeys
key 1
key-string 0 cisco

interface overlay1
otv isis authentication md5
otv isis authentication key-chain OTVkeys

2.控制层面认证(认证不通过建不了邻居)

otv-isis default
vpn overlay1
authentication-check
authentication-type md5
authentication key-chain OTVkeys

三、OTV VLAN Translation
解决两数据中心的两端VLAN号不一致
DC1 vlan 100—— DC2 vlan 200

只需要在DC1配置一条命令:
interface overlay0
otv vlan mapping 203 to 303

show otv vlan-mapping

CCIE-DC学习笔记3–VPC

配置vPC
1.激活特性
feature vpc
feature lacp

2.配置domain
vpc domain 73
role priority 73 (小的为主)
system-priority 2500

3.配置peer-keepalive (三层路由链路,承载心跳,进行双active检测)

peer-leepalive destination x.x.x.x source x.x.x.x

4.配置peer-link(直连,二层,承载控制层面流量,两端的板卡类型要一致。10Ge only)

interface e3/1-2
channel-group 20 mode ative
no shut

interface port-channel 20
switchport mode trunk
vpc peer-link

5.上联两台设备配置port-channel
feature lacp

interface e3/4
channel-group 30 mode active
no shut

interface port-channel 30
switchport mode trunk
vpc 30

6.下联一台设备配置port-channel

interface e3/1-2
channel-group 30 mode active

interface port-channel 30
switchport mode trunk

7.检查
show vpc

show vpc consistency-parameters interface port-channel 30
type 1 必须一致 ,type 2 可以不一致

vPC中HRSP行为是被修改的,所有HSRP路由器都会主动转发收到的流量

vPC Peer Switch特性 两台设备模拟一个MAC发BPDU

vPC二层技术

watch glee episodes joomla themes Wordpress主题站 templates2joomla